Home Menu

Menu


Closed
 
Thread Tools Display Modes
Old March 13th, 2017, 08:17 AM #1
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



Posting Images in HTTPS instead of HTTP

As it was announced last week, we've switched to using SSL. What this means is the link to RangerBoard uses HTTPS in the beginning instead of HTTP.

When you view RangerBoard on its default page, there should be a green status that looks like this:



The status is green because all images hosted by RangerBoard are secured by SSL.

If you load a thread, and someone posted an HTTP image, then this warning can appear:


While it's not really a security issue, it's not best practice. So please do try to post HTTPS image links only. TinyPics & Imgur supports HTTPS. While it appears Photo Bucket does too, you have to type it in during the post, not the actual link. It'll redirect to HTTP otherwise.

It only poses a privacy issue. So if the Internet connection you're on can be compromised, like a public Wi-FI for example, then someone can see which images you're viewing.

Anything going through HTTPS is encrypted and privatized.

So of course, an HTTPS link looks like this:
Code:
https://f.RangerBoard.com/RBFF_secure.png
And a NON-HTTPS aka HTTP link looks like this:
Code:
http://f.RangerBoard.com/RBFF_secure.png
While it's not required for users to change everything over to HTTPS, it would be best to start getting into this habit. Any non-secure warnings are not the issue of RangerBoard itself.

HTTPS is fully explained in this video as well:


Please share any questions/concerns here.
Decade is offline    
Old March 13th, 2017, 02:47 PM #2
andr0s81's Avatar
> andr0s81
100% Grade "A" Final Boss
 
Joined: Feb 2004
Posts: 7,164
4 eBay
andr0s81
100% Grade "A" Final Boss
andr0s81's Avatar
 
Joined: Feb 2004
Posts: 7,164
4 eBay



My apologies if this is a dumb question, but would this also to the IMG tags on photobucket, or just the HTLM?
andr0s81 is offline    
Old March 13th, 2017, 02:49 PM #3
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



andr0s81 wrote: View Post

My apologies if this is a dumb question, but would this also to the IMG tags on photobucket, or just the HTLM?
Just the image tags, RangerBoard's posts doesn't support HTML.
Decade is offline    
Old March 13th, 2017, 03:13 PM #4
a squad's Avatar
> a squad
Gettin Supercharged Up
 
Joined: Aug 2005
Posts: 4,091
a squad
Gettin Supercharged Up
a squad's Avatar
 
Joined: Aug 2005
Posts: 4,091



So since PB doesn't support HTTPS does that mean I'll have to find another site to use?
a squad is offline    
Old March 13th, 2017, 03:40 PM #5
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



a squad wrote: View Post

So since PB doesn't support HTTPS does that mean I'll have to find another site to use?
It would be better to. It's not against the rules or anything to continue using Photo Bucket.

But you'd be the person to blame for unsecure warnings people see, not RangerBoard itself.
Decade is offline    
Old March 13th, 2017, 03:59 PM #6
Gold Samurai's Avatar
> Gold Samurai
Power Ranger
 
Joined: Jun 2003
Posts: 29,476
Gold Samurai
Power Ranger
Gold Samurai's Avatar
 
Joined: Jun 2003
Posts: 29,476



Decade wrote: View Post

While it's not really a security issue, it's not best practice. So please do try to post HTTPS image links only. Photobucket doesn't appear to support HTTPS. TinyPics & Imgur does.
I'm using IMGUR to post pictures but none of these are HTTPS?

http://imgur.com/a/Yph5L
Gold Samurai is offline    
Old March 13th, 2017, 04:04 PM #7
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



Gold Samurai wrote: View Post

I'm using IMGUR to post pictures but none of these are HTTPS?

http://imgur.com/a/Yph5L
Manually change your link:
https://imgur.com/a/Yph5L
Decade is offline    
Old March 13th, 2017, 04:12 PM #8
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



I guess I was wrong, Lord Zedd managed to post Photo Bucket images as HTTPS:
https://www.RangerBoard.com/showpost...40&postcount=1

I thought it wasn't supported because when you type in HTTPS, it redirects it to HTTP.

But it appears as long as you post it as HTTPS, it works.
Decade is offline    
Old March 13th, 2017, 04:15 PM #9
spikebuster's Avatar
> spikebuster
Power Ranger
 
Joined: Nov 2011
Posts: 223
spikebuster
Power Ranger
spikebuster's Avatar
 
Joined: Nov 2011
Posts: 223



So that's why my tablet called this site a security risk and prevents me from from viewing the site on it. Thanks for the explanation.
spikebuster is offline    
Old March 13th, 2017, 04:21 PM #10
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



spikebuster wrote: View Post

So that's why my tablet called this site a security risk and prevents me from from viewing the site on it. Thanks for the explanation.
Actually it should not prevent you from viewing it.

It only prevented earlier on because before we switched to the paid SSL, the server had its own self-signed SSL. Which we never actually used.

Self-signed SSLs are not properly verified by SSL Certificate Authorities. After we installed the paid one, it still took some time for your device's DNS to properly update to the new one.
Decade is offline    
Old March 13th, 2017, 04:57 PM #11
Gold Samurai's Avatar
> Gold Samurai
Power Ranger
 
Joined: Jun 2003
Posts: 29,476
Gold Samurai
Power Ranger
Gold Samurai's Avatar
 
Joined: Jun 2003
Posts: 29,476



Decade wrote: View Post

Manually change your link:
https://imgur.com/a/Yph5L
Ah I see. I'll have to add an "S" to each HTTP link

Gold Samurai is offline    
Old March 13th, 2017, 04:59 PM #12
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



Gold Samurai wrote: View Post

Ah I see. I'll have to add an "S" to each HTTP link

https://imgur.com/nOqvdn3.jpg
Actually, since I added to the link you provided earlier on:
https://imgur.com/a/Yph5L

All the images on this page now has the S in the HTTP, so if you copy the links from here, they're the correct links.
Decade is offline    
Old March 15th, 2017, 09:41 AM #13
Kylash327's Avatar
> Kylash327
PlasticGeek
 
Joined: Jun 2004
Posts: 4,062
128
Kylash327
PlasticGeek
Kylash327's Avatar
 
Joined: Jun 2004
Posts: 4,062
128



This would seem like something that could/should be done on the forum side doesnt it? Isnt there a way to detect http: being entered into any input field and do a replace when submitted?
Kylash327 is offline    
Old March 15th, 2017, 09:44 AM #14
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



Kylash327 wrote: View Post

This would seem like something that could/should be done on the forum side doesnt it? Isnt there a way to detect http: being entered into any input field and do a replace when submitted?
So far from what I can tell, that's not possible.

The best I was able to do was replace the "http" suggestion when it pops up in the image tags.

However, users can overwrite that by pasting in the link. A conflict too is if there is a way to force in HTTPS, if users post http:// or https://, then it would cause broken links due to: htts://https:// or https://http://

While it's ideal for the site to some how replace http:// links with https://, something like it doesn't appear to exist. A developer has to create something like that. And I'm not a Developer.
Decade is offline    
Old March 17th, 2017, 09:06 AM #15
TealMystechRanger's Avatar
> TealMystechRanger
or AcceLOWorst
 
Joined: Mar 2014
Posts: 12,483
TealMystechRanger
or AcceLOWorst
TealMystechRanger's Avatar
 
Joined: Mar 2014
Posts: 12,483



Some images don't seem to load when I add an s to their URLs. I tried to post an image in the SH Figuarts thread last night and it loaded as an [x] with https - luckily I found a Twitter upload of the same image, which has https by default. I've just had a similar issue with a post in the Digimon thread, where none of the images displayed when I changed them to https. (I think I'll go and find alternative links for each of them too, since obviously posting with http isn't preferable.)

Neither of these were host site images. One was... the Daily Star, I believe? A British tabloid... I just found the image on Google. The Digimon ones are all from Digimon forum With The Will. I don't believe it's a universal "other sites" issue as images from TFW2005 have loaded fine with https when I posted them in the Transformers thread.

Just felt I should bring this to your attention.
TealMystechRanger is offline    
Old March 17th, 2017, 09:08 AM #16
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



That's not to do with us. That's whoever was hosting those images, not being able to support HTTPS. That was anticipated as it was discussed earlier on that PhotoBucket may be an issue.
Decade is offline    
Old March 17th, 2017, 09:12 AM #17
TealMystechRanger's Avatar
> TealMystechRanger
or AcceLOWorst
 
Joined: Mar 2014
Posts: 12,483
TealMystechRanger
or AcceLOWorst
TealMystechRanger's Avatar
 
Joined: Mar 2014
Posts: 12,483



Ah, fair enough. I've managed to find suitable links and have replaced all the images in the aforementioned post.
TealMystechRanger is offline    
Old March 17th, 2017, 06:58 PM #18
DigitalBrave3's Avatar
> DigitalBrave3
Mystech Movie Villain
 
Joined: Aug 2016
Posts: 259
DigitalBrave3
Mystech Movie Villain
DigitalBrave3's Avatar
 
Joined: Aug 2016
Posts: 259



People really need to read this stuff, because nobody has been doing this at all.
DigitalBrave3 is offline    
Old March 17th, 2017, 07:13 PM #19
Decade's Avatar
> ϟDecade
FINAL KAMEN ATTACK FORM RIDE: OWNER
 
Joined: Jul 2004
Posts: 32,664
1
Decade
FINAL KAMEN ATTACK FORM RIDE: OWNER
Decade's Avatar
 
Joined: Jul 2004
Posts: 32,664
1



I was just able to implement a way to convert HTTP to HTTPS. So this won't matter anymore, except for the exact that unsupported HTTP images won't work.

HTTP images should be posted as links instead.
Decade is offline    
Closed

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

 

Connect







 

Design

    RangerBoard designs are exclusive to Members.
    Please login to access all available designs.

All times are GMT -7. The time now is 09:14 AM.
Powered by vBulletin® / Copyright ©2000 - 2019, vBulletin Solutions, Inc.